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Flash – Basics: Overview 
 
1. Basics of vector graphics and drawing in Flash 
 Draw basic shapes with the Oval and Rectangle tools 
 Colors and the fill and stroke 
 Editing shapes 
  
2. Using layers and the timeline 
 Creating, naming, and moving layers 
 Shapes and drawing with different layers 
  
3. Symbols and their use with the library window 
 Types of symbols 
 Creating a symbol 
 Editing a symbol and its timeline 
 
4. Animation with keyframes 
 Creating a keyframe 
 Moving symbols 
 Tweening 
 Shape animation 
 Adjusting the animation (moving keyframes, easing) 
 
5. Buttons 
 Creating a button 
 The button timeline 
 Choosing button states 
 
6. Simple Actionscript 
 Timeline control 
 Button actionscript 
 Loading a web page 
 
7. Publishing the Project 
 Choosing output types 
 Publishing 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



FLASH BASICS ACTIVITIES 
 
Basics of vector graphics and drawing in Flash 
 
 
1. 

 
Draw basic shapes with 
the Oval and Rectangle 
tools 

 
- Flash uses vector graphics for all its visual elements. 
- Vector graphics are not like painting, it’s more like just 

creating shapes that are very editable. 
- Try the Oval tool (o) or Rectangle Tool (r) and click 

and drag out the shape on the stage. 
 

 
2. 
 

 
Colors and the Fill and 
Stroke 
 

 
- With the Selection tool (v), you can select various 

pieces of your shape.  The outside edge is called the 
“stroke” and the inside is called the “fill”.  When 
selected, a piece will have white dots in it making it 
highlighted. 

- Once highlighted, you can change the colors using the 
Color Mixer (if you don’t see it, go to Window > Color 
Mixer at the top of the screen). 

 
 
3. 

 
Editing Shapes 
 

 
- If you put the mouse to the edge of your shape, its 

icon will change, and you can click and drag the shape 
around. 

- The Properties box at the bottom of the screen allows 
you to change things about your shape, including the 
color, the size of the stroke, and the type of stroke. 

 
 
 
 
Using Layers and the Timeline 
 
 
1. 
 

 
Creating, Naming, and 
Moving Layers 

 
- The timeline is at the top of the stage, and is where 

the layers are located. 
- Layers in Flash behave exactly as they do in 

Photoshop – they can be thought of as transparent 
pieces of paper laid one on top of another.  You can 
put shapes on each layer and they will behave 
independently of other layers. 

- To create a new layer, click on the icon of the page 
with a blue plus-sign on it. 

- You can (and should) rename all layers by double-
clicking on the words “Layer #” where # is the number 
of the layer. 

- To move a layer, simply click on its name and drag it 
above or below the other layers. 

 
 
2. 
 

 
Shapes and Drawing with 
Different Layers 

 
- Each layer has its own timeline space.  You can move 

objects on one layer without affecting the other layers 
in any way. 

- Create a new layer and the draw a shape on it, on top 
of the shape on the layer below. 



- In the timeline, drag the layer with the new shape 
below the layer with the old shape, and they will switch 
places, one on top of the other. 

 
 
 
 
 
Symbols and their Use with the Library Window 
 
 
1. 
 

 
Types of Symbols 

 
- A Symbol is a special kind of Flash object.  It has its 

own timeline, can be copied any number of times on 
the stage (“instancing”), and can be controlled with 
actionscript. 

- There are three types of Symbols: a “Movie Clip”, a 
“Button”, and a “Graphic”. 

- A Movie Clip can be changed, moved, and edited with 
actionscript, making it especially powerful.   

- A Button acts as a button, which can be told to do 
anything you want it to do, such as load a web page or 
move to a different part of the animation. 

- A Graphic is like a Movie Clip, but is static, and can’t 
change around as much. 

 
 
2. 

 
Creating a Symbol 

 
- To create a symbol, select a shape or graphic you 

have on the stage, and right-click (windows) or ctrl-
click (mac).  Select “Convert to Symbol…” in the menu 
that pops up.  Alternatively, you can go to Modify > 
Convert to Symbol… at the top of the screen. 

- In the window that pops up, name your symbol, and 
choose a type. 

- Your symbol will show up in the Library on the right 
side of the screen.  If you don’t see the Library, go to 
Window > Library at the top of the screen. 

- Your new Symbol will be a complete object, instead of 
individual editable parts such as a stroke and fill. 

- You can create copies (instances) of your Symbol by 
dragging it from the library onto the stage.  If you 
change one of the instances of the symbol as per the 
directions below, it will change them all. 

 
 
3. 

 
Editing a Symbol and its 
Timeline 

 
- Once you create a Symbol, it will have a turquoise-

colored box around it.  To edit it, such as changing its 
shape or color, double-click on it.  Everything else on 
the stage will fade, and the timeline will change. 

- Each symbol has its own timeline, independent of the 
main timeline for the stage itself.  This allows you to 
have a lot of control over the movement of your 
objects. 

- To go back to the main timeline and the rest of your 
objects, click on the words “Scene 1” at the top of the 
Timeline. 

 



Animation with Keyframes 
 
 
1. 

 
Creating a Keyframe 

 
- To create a keyframe, select a frame in the Timeline 

on the layer of the symbol you want to move and right-
click it (windows) or ctrl-click it (mac), and select 
“Insert Keyframe”. 

- A black dot will show up in that frame, and the frames 
between that keyframe and the previous one will be 
shaded. 

 
 
2. 

 
Moving Symbols 

 
- Click on your new keyframe to select it, then, with the 

Selection tool (v), click and drag your symbol on the 
stage to a different place on the stage. 

- If you drag the red timeslider of the Timeline back and 
forth, you will see your symbol jump from one place to 
another. 

 
 
3. 

 
Tweening 

 
- Tweening creates a smooth movement between 

keyframes, so your object won’t jump from one place 
to another. 

- Right-click (windows) or ctrl-click (mac) on the timeline 
in-between the two keyframes where you want smooth 
animation.  In the menu that pops up, click on “Create 
Motion Tween”. 

- An arrow will point from one keyframe to the other, 
and the frames will be shaded blue.  Drag the red 
timeslider back and forth, and your symbol will 
smoothly move from one place to the other, across the 
stage. 

 
 
4. 

 
Shape Animation 

 
- To animate the shape and not just the position of your 

object, first select the keyframe in the Timeline where 
you want your object to be a different shape (or create 
a new keyframe).  This will also select your symbol. 

- Select the Free Transform Tool (t), it is directly under 
the Selection tool, and a new box will show up around 
your symbol on the stage.  Click on one of the little 
square boxes and drag to change the shape of your 
object. 

- Drag the timeslider back and forth between the 
keyframes, and you will see your symbol change 
shape smoothly (if you have added the tweening). 

 
 
5. 

 
Adjusting the Animation 

 
- To slow down or speed up your animation, you can 

simply move your keyframes.   
- Select a keyframe by clicking on it, then click and drag 

the keyframe up or down the timeline.  The farther you 
move it from the keyframe before it, the slower your 
animation will be, and the closer you move it, the 
faster it will be (because you have the same 
movement in more or less time). 



- You can push alt-enter (windows) or apple-enter (mac) 
to watch your animation. 

- You’ll notice that the movement of your symbol is a 
little jerky.  To smooth it out, you can add easing to the 
animation. 

- Click on the first keyframe of the animation of your 
object, then look at the Properties box at the bottom of 
the screen. 

- One of the values you can change is “Ease”.  Click on 
the button with the arrow and drag the Ease value all 
the way up to 100 (out). 

- Watch your animation, and your symbol will start 
moving quickly, but then slow down to a stop at the 
second keyframe. 

 
 
 
 
 
Buttons 
 
 
1. 

 
Creating a button 

 
- To create a button, first draw the shape of the button 

on the stage – any shape and color you want. 
- If you want text on the button, use the text tool and 

type it directly on top of your shape (make sure it’s on 
the same layer). 

- Select the entire shape and any text you might have 
by using the Selection tool (v) and dragging a 
selection box around it. 

- Right-click (windows) or ctrl-click (mac) and select 
“Convert to Symbol…” in the menu that pops up. 

- Name your button, and pick “Button” for the type. 
 

 
2. 

 
The Button Timeline 

 
- Double-click on your newly created button, and then 

look at the timeline. 
- Buttons have their own special timelines, which 

contain four frames, one for each state. 
- “Up” is the state of the button when it is just sitting 

there and nothing is happening to it. 
- “Over” is what the button looks like when the mouse 

cursor is sitting over it. 
- “Down” is what the button looks like when the mouse 

button is clicked on it. 
- “Hit” is the shape of the area that is clickable on the 

button. 
 

 
3. 

 
Choosing Button States 

 
- In your button’s timeline, right-click (windows) or ctrl-

click (mac) and insert a keyframe to the “Over” state. 
- Select your button with the Selection tool (v), and 

change the color of the fill a little bit. 
- Do the exact same above two steps again for the 

“Down” state. 
- In the “Hit” state frame, just add a keyframe – nothing 



else needs to be done there. 
- Click on the words “Scene 1” at the top of the timeline 

to get back to your main timeline and the stage. 
- Push alt-enter (windows) or apple-enter (mac) to view 

your animation, and try moving the mouse over and 
clicking on your button. 

 
 
 
 
 
Simple Actionscript 
 
 
1. 

 
Timeline Control 

 
- First, make sure you have some sort of animation, 

such as after you complete the Animation with 
Keyframes section above. 

- If you preview your movie, you’ll see that it just keeps 
repeating over and over. 

- Click on the last keyframe of your animation to select 
it, and then open the Actions window if it’s not already 
open (go to Window > Actions). 

- In the Actions window, type 
 
stop(); 
 
- Do not forget the semicolon at the end! 
- You’ll see a little ‘a’ above your keyframe, that means 

there is actionscript on the frame. 
- Preview your movie, and it will stop at the end of your 

animation. 
 

 
2. 

 
Button Actionscript 

 
- Add a button to your above animation on a different 

layer. 
- Make sure you’re on the main timeline after making 

the button’s states (you’ll see the two layers).  Click on 
the button on the stage to select it. 

- In the Actions box (make sure it says Actions – Button 
at the top of the Actions box), type 

 
on(press) { 
 gotoAndPlay(1); 
} 
 
- Now preview your animation.  It will play and then 

stop, and then if you push the button, it will play again.  
The code gotoAndPlay(1) goes back to frame 1 when 
the button is pressed. 

 



 
3. 

 
Loading a Web Page 

 
- Click on the button again and change the above code 

to this: 
 
on(press) { 
 getURL('http://www.smith.edu'); 
} 
 
- Now preview your animation and click on the button.  

Your default browser will open to the Smith 
homepage! 

 
 
 
 
 
Publishing the Project 
 
 
1. 

 
Choosing output types 

 
- Once you have a finished animation, go to File > 

Publish Settings… 
- There are many types of end files available.  If you 

want your animation to be in a web page, Flash can 
create that page automatically for you if you have the 
HTML (.html) and Flash (.swf) boxes checked. 

- If you want a stand-alone windows program that will 
run from your computer and not the internet, check the 
Windows Projector (.exe) box. 

- If you want a Quicktime movie, check the QuickTime 
(.mov) box.  Note that you cannot have buttons or any 
actionscript at all in a quicktime movie. 

 
 
2. 

 
Publishing 

 
- Push the Publish button or go to File > Publish, and 

your output choices will be saved to the directory your 
original Flash file is saved. 

- If you picked the Flash (.swf) and HTML (.html) boxes, 
go to your save directory and upload these two files to 
your website. 

- Direct your favorite browser to your website to the 
name of your .html file to view your amazing animation 
on the web! 

  
 


